eclipse下python安装scrapy以及切换python版本

发布时间:2017-09-10 10:13:34
eclipse下python安装scrapy以及切换python版本

这里主要记录一下有关在windows下scrapy的安装以及安装过程中碰到的问题以及解决办法。

\

意思是说scrapy需要依赖于lxml,parselw3lib,twisted,cryptography,pyOpenSSL

而测试版最小需要 twisted ,lxml,pyOpenSSL这三个

■开始安装

1 开始-cmd

依次执行以下语句:

2 python -m pip install lxml

3 python -m pip install parsel

4 python -m pip install w3lib

5 python -m pip install cryptography

6 python -m pip install pyOpenSSL

界面大概是这样的,不一详表。

\

7 安装twisted :之后在用python -m pip install twisted命令时出现了问题

\

说我还需要安装microsoft visual c++ 14.0,网上有解决办法是安排好后面给的网址去安装visual c++能解决,而我选择了后者,通过whl来安装

\

记得要找python版本相对应的whl,我的机器对应的是64位的windows,python版本为3.5.4,经过尝试,cp35-win32的可用。不知道自己python版本的在cmd下输入python即可,如7中图红字下方

9 安装twisted

首先进入到文件下载目录中。然后执行 python -m pip install Twisted-17.5.0-cp35-cp35m-win32.whl

\

10其实安装过程中可以看到所安装的包其实是放在python目录的lib\site-packages下,找这个还找了半天。

11 最后,才是安装scrapy: python -m pip install scrapy

至此,搞定scrapy

■在eclipse下切换ptyhon版本

因为我装了两个不同版本的python 顺带说一下eclipse怎么切换python的版本

路径为 :eclipse - preferences - PyDev - Interpreters - Python Interpreters。右侧选择你所的版本,最后OK。

\

然后在你的项目工程 properties -pydev - interpreter下切换python版本。

\

企业建站2800元起,携手武汉肥猫科技,做一个有见地的颜值派!更多优惠请戳:武汉网站推广 https://www.feimao666.com

上一篇:.NET 代码规范学习
下一篇:最后一页